Results 1 to 3 of 3
  1. #1
    Member Chix's Avatar
    Join Date
    Oct 2015
    Location
    Calgary
    Posts
    33

    Fish are loosing color after an ICH treatment

    Hi there,
    Some of my fish had ICH, so I treated them using the herbal ICH treatment that I got from my local aquarium store and I also had to raise the temperature during the treatment and lowered the temperature gradually back to the way it was after I was done.

    Now it seems like some of my fish have lost their bright colors after the treatment, does anyone know what the cause of this? And how to fix it?

    Thanks!

  2. #2
    Junior Member Lauri's Avatar
    Join Date
    Oct 2015
    Location
    AB
    Posts
    8
    Sorry to hear you're dealing with ICH in your aquarium, I'm not sure what could be the cause but I recommend you change the water on a large scale and leave only enough water for the fish to swim. You should also look out for Old Tank Syndrome, but large water change will help with that.

  3. #3
    Member Chix's Avatar
    Join Date
    Oct 2015
    Location
    Calgary
    Posts
    33
    Quote Originally Posted by Lauri View Post
    Sorry to hear you're dealing with ICH in your aquarium, I'm not sure what could be the cause but I recommend you change the water on a large scale and leave only enough water for the fish to swim. You should also look out for Old Tank Syndrome, but large water change will help with that.
    I did what you said and I think it starting to work, I can't tell for sure as it's still early but I'm crossing my fingers. Thanks for the tips!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •