Results 1 to 6 of 6

Thread: PhosLock

  1. #1
    Senior Member kennyfish's Avatar
    Join Date
    Nov 2005
    Posts
    133

    PhosLock

    I just started using an Iron based Phosphate remover in my tank. I have it set up passive with a media bag suspended in the upflow side of my baffles.

    I started using this in the hope of eliminating briopsis and some slime algae. Do you think this method is going to help?

  2. #2
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    hmmmmm can you post a pic???


    i would be a little concerned about the GFO leaching any Fe that the algae could use. but yes removing PO4 is always a good start but it's best run in a reactor.

    for bryopsis the most common cure at the moment is to use Kent tech M to raise your Mg to ~ 1650ppm for a couple of weeks. there has been a lot of discussion as to whether it is the Mg or something else in the Kent product but this is the brand of choice.

    good luck and post a pic, just to be sure
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  3. #3
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    sorry also forgot to mention, raise it gradually, no more than ~ 100ppm per day.
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  4. #4
    Senior Member kennyfish's Avatar
    Join Date
    Nov 2005
    Posts
    133
    I have read a bit about the Mg thing at RC. I was thinking of switching to one of the high Mg salt mixes from the basic IO I am using now.

  5. #5
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    that wont work, the Kent Tech 'M' has something in it that helps, not just any Mg supplement or source.
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  6. #6
    Senior Member kennyfish's Avatar
    Join Date
    Nov 2005
    Posts
    133
    ok thanks. looks like i need to get more test kits :b5:

Similar Threads

  1. PURA PhosLock
    By Weddel Tech Support in forum Filters/Filter Media
    Replies: 0
    Last Post: 03-31-2006, 05:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •