Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Aug 2010
    Posts
    2

    all starfish died, nothing else

    I got some api ph 8.2 fix stuff because my water test showed my ph was off, so I do that, within 24 hours all 30+ of my tiny brittle starfish are bottom up... they came hitchhiking on my live rock but i'm just puzzled... my tank is over a year old, it's 90 gallons with 90 lbs of live rock... I also did ammo fix at the same time, could that be why? is it bad to fix two water properties at once?

  2. #2
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    star's are sensitive to changes in water parameters as well as O2 levels and rapid changes may cause a die off.


    what was your pH??

    how do you test you pH?

    what salt are you using??

    what additives do you use?


    i'm not familiar with "ammo fix" but it sounds like its to help with high ammonia ( NH3) levels ??? high levels ( which isn't much ) of ammonia could also cause a die off for the stars and much more if not corrected.

    can you tell us a little more about your system and how you maintain it???

    HTH
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  3. #3
    Junior Member
    Join Date
    Aug 2010
    Posts
    2
    I thought it was bad... then I got home yesterday... the water was cloudy and "everything" in my tank is now dead...

    there are bugs that were living in my live rock strewn about the sand, my goby, scooter, copperband butterfly, porcelain crab, snails, hermit crabs, cleaner shrimp, peppermint shrimp... everything is dead...

    I tested the ammonia and it read at the full 8ppm...

    I don't understand how my ammonia could get so high in so little time... my purple tipped anemone died and I read that this could be the cause, my brain also died... it seems like every time something dies the ammonia gets worse so I can't fix it

    what do I do?

  4. #4
    Senior Member
    Join Date
    Jul 2008
    Posts
    190
    I believe your ammonia reading is not the root cause, it is the affect of the losses. The question is... what caused the initial loss of your starfish as these seem to be the first losses in your tank.

  5. #5
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    sorry to hear about the losses :b1:

    Quote Originally Posted by RossW View Post
    I believe your ammonia reading is not the root cause, it is the affect of the losses.
    i agree, sounds like things started to snowball after the death of the anemone (??? not sure of the actual time line ..... ), is this why you needed the ammo fix??
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  6. #6
    Senior Member
    Join Date
    Jan 2007
    Posts
    612
    And I was upset I noticed my bicolor blenny is missing. Sorry for the loss. I'd be quite upset losing everything like that.:b9:
    120g AGA~145 lbs Haitian LR~DA Reef Keeper 2 Controller~Dual 14k 250 DE MH's~Dual Overflows~Dual 250w Jager Heaters~Dual 96W Actinics~30g Sump/Refugium~Mag 12 Return~140 lbs Reefgrade Caribsea Aragonite~BubbleKing 180 Skimmer~Phosban Reactor~GEO Kalk Reactor~Powerheads:MP40w/Seio 820/modified Powersweep 270 with Hydor rotating deflector~Digital lighting timer for moon/fuge lighting~7 stage RODI filtration~Quarantine: modified 12.5g Marineland Eclipse

Similar Threads

  1. starfish died
    By wend121 in forum Water Quality
    Replies: 8
    Last Post: 09-29-2008, 09:19 PM
  2. Velocity T4 died...?
    By i2ik in forum Lighting, Filtration & Other Equipment
    Replies: 5
    Last Post: 12-02-2005, 05:23 PM
  3. lighting died
    By nbreau in forum Reef Discussion
    Replies: 2
    Last Post: 09-14-2004, 05:47 PM
  4. New Blennie Died
    By Jeeves in forum Just Getting Started
    Replies: 6
    Last Post: 05-31-2004, 01:34 PM
  5. My skimmer just died
    By AndrewNS in forum ARRG
    Replies: 8
    Last Post: 02-01-2004, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •