Results 1 to 2 of 2
  1. #1
    Senior Member
    Join Date
    Jun 2004
    Posts
    715

    berlin skimmer: working or not?

    I have been running my berlin skimmer for 1 week now and it works but it has 2 returns going in the sump. Only 1 return works the other does nothing(no water comming out). Is this normal or is this a question of time? The guy who set it up told me to move it around, tilt etc.... did not work. He will come over saturday but if anyone has an answer to this prob, please let me know.

  2. #2
    Senior Member
    Join Date
    Aug 2003
    Posts
    5,122
    I would take it apart and check for something blocking it. Both outputs should work right away when you turn it on.

Similar Threads

  1. berlin skimmer
    By rayzzfish in forum Lighting, Filtration & Other Equipment
    Replies: 4
    Last Post: 12-20-2006, 01:38 PM
  2. Berlin Skimmer with Mag 9.5 pump
    By Lawnmower_Goby in forum Reef Discussion
    Replies: 0
    Last Post: 02-17-2006, 02:53 AM
  3. Berlin Skimmer MOD
    By One Salty Dog in forum DIY - Do it Yourself
    Replies: 31
    Last Post: 07-22-2005, 01:01 PM
  4. Help please with Berlin turbo Skimmer.
    By One Salty Dog in forum Lighting, Filtration & Other Equipment
    Replies: 8
    Last Post: 01-11-2004, 01:55 AM
  5. F/S Berlin Skimmer
    By MINIATUS in forum AC Classifieds
    Replies: 3
    Last Post: 01-05-2004, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •