Page 2 of 17 FirstFirst 123412 ... LastLast
Results 11 to 20 of 170
  1. #11
    Senior Member
    Join Date
    Apr 2003
    Posts
    6,370

    Cool

    when you say everything that means more than 1 fish.
    your tank is only 12 weeks old. So I have a feeling you just setup ans stalked your tank full of fish. not good. in this hobby you have to go pain stakinly slow and research before you add anything would be a good idea. how much liverock do you actually have in there? do you have a sump? flow sounds non existent [just the canister?] make sure you condition your tap water as well and I'd let your saltwater sit and mix for a few days before doing your water changes.make sure its at the same temp as the tank.

  2. #12
    Senior Member TaCtIkZ's Avatar
    Join Date
    Oct 2003
    Posts
    118
    One more thing to add to all of this... Are you using used equipment? I've experienced unwanted algae blooms when my MH came to near the end of their lifespan as the output spectrum changed. If you bought the MH bulb used, that might be causing your red algae bloom, or at least helping it along.

  3. #13
    Senior Member tiffany's Avatar
    Join Date
    Sep 2003
    Posts
    860
    You have some great adice above.
    It's not uncommon to have these sorts of problems when starting out.
    I agree to wait 6 weeks for the ich to rid. (I did this when I had ich and it hasn't returned).
    The lack of fish will also decrease nitrates due to lower feeding, and you should find that the algae willl starve and die, make sure to help it along with syphoning, and good flow.

    Tiff.
    "The significant problems we face cannot be solved at the same level of thinking we were at when we created them."
    - Albert Einstein (1879-1955)

  4. #14
    Senior Member Fisherman's Avatar
    Join Date
    Apr 2003
    Posts
    1,408
    little story for you.. i started a 20 gal nano a year ago.. and well i started it up and was testing. watching... learning.. then about 2-3 months later i got a bad Cyno outbreak.. everyday i had to suck out cyno.. it covered everything. i used turkey baster and net sometimes.. It took about 1.502 months for my tank to balance it out and looked like crap. but i kept cleaning and doing water changes.. then i got hair algae and i almost quit i got so pissed off i hated the tank.. but again everyone here told me to relax and let the tank balance itself.. and about a month or so later is wat gone.. and ever since i have had no algae problems..

    tank is 15 months old now.. just thought this story might help you..

  5. #15
    Senior Member
    Join Date
    Jan 2004
    Posts
    356
    Do not get discouraged. I have had my share of problems with cyano, hair algae and bubble algae in the beginning. My tank is two years old now, and very stable. Go slowly. I did a good one year of reading before having a tank and putting water in it. Patience pays off. But I understand your frustration. Hang in there.

  6. #16
    Senior Member volitan's Avatar
    Join Date
    Dec 2003
    Posts
    3,051
    Also how often do you clean your canister?If you leave it not cleaned it is a nitrate factory in there and algea does love it....Ever considered A uv light?
    Derik...

  7. #17
    Senior Member princpl skimmer's Avatar
    Join Date
    Jan 2005
    Posts
    246
    what makes you a good reefer is getting past that point. you are rushing regardless of what you can easily convince yourself of. weve all been there. think thats bad, wait till youve been doing this for 5-6 years and that happends. atkeast you have an excuse. the fact that your tank is practiclly a newborn.

  8. #18
    Senior Member
    Join Date
    Jun 2004
    Posts
    715
    Where did you get all your equip and live goods? I hope it wasen't at aquatropicale. As others mentionned take it slow. What is your salinity at? Do you test your water? If not, start testing right now. Do you use RO/DI water? Add flow asap. How long did you wait befor adding corals and fish? Did your tank cycle prior to adding your live goods. I think that ick should be your last concern right now and you chould concentrate on your water quality and do not add a single fish for a while.

  9. #19
    Member
    Join Date
    Dec 2004
    Posts
    44
    thanks everyone for your responses, but to respond to a few of your questions, i have 2 powerheads 802's, the 400w bulb is new but i am supplementing with both a marine glow and a power glow. my salinity is at 1.026 hope i didn't forget anything

  10. #20
    Senior Member
    Join Date
    Apr 2003
    Posts
    6,370

    Cool

    the problem is very clear, to many fish, not enought time. what amount of liverock do you have? what skimmer are you using? very important things.

Page 2 of 17 FirstFirst 123412 ... LastLast

Similar Threads

  1. wanna play
    By Asmodeus in forum Off Topic
    Replies: 1
    Last Post: 09-22-2005, 01:58 PM
  2. I wanna fish?
    By Rentaltux in forum Reef Discussion
    Replies: 5
    Last Post: 02-16-2005, 05:22 AM
  3. ANYONE wanna Split Shipping to T.O?
    By aquamann in forum Off Topic
    Replies: 0
    Last Post: 06-28-2004, 02:59 PM
  4. Replies: 0
    Last Post: 06-28-2004, 03:27 AM
  5. Wanna see my new football?
    By Flame*Angel in forum Reef Discussion
    Replies: 21
    Last Post: 03-27-2004, 03:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •