Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    Senior Member pwall's Avatar
    Join Date
    Nov 2004
    Posts
    2,326

    Off-topic: Linux/Samba config issue

    Definitely not fish related...but definitely related to my sanity.

    I have Fedora 6 installed and have samba configured to share out a couple of directories to my WindowXP boxes (home setup).
    Anyways, I can mount any directory that is shared out, except for /home, which is a seperate disk (ie. not part of the root disk).
    I've tried just about everything but can not get /home to mount.

    Anyone have any linux/samba knowledge that they could share ?

    Thanks!
    Regards,
    Patrick.
    Ottawa (Orleans), Ontario
    Yahoo IM: pwallnfld

  2. #2
    Senior Member DARK's Avatar
    Join Date
    Aug 2004
    Posts
    1,765
    Install XP...

  3. #3
    liv
    liv is offline
    Former Moderator liv's Avatar
    Join Date
    Dec 2003
    Posts
    5,646
    first check what kind of file system you want to mount.. fedora might have restrictions with ntfs partitions.. check on the fedora sites on how to mount an ntfs or fat32 partition.
    You could always try... something like ex:

    mkdir -P /mnt/share
    chown rootther /mnt/share
    sudo mount -rw 192.168.0.5:/whateverwindowsxpfolderyouwant /mnt/share
    of course syntax will change .. but its the same basic idea.

    check if you can see files inside /mnt/share by dropping a file on your windows shared folder designated above.

    the server being the windows xp box.
    the way i've done it on mine was to mount it at startup in the /etc/vfstab as rw then i was able to use it with everything. I use Ubuntu.. but have been a longtime Redhat/Fedora fan in the past.. but i moved on to something that suits me more.

    on my latest ver of Ubuntu.. its preconf and finds anything with an NT domain and workgroup.. so no work at all to do.. it sees it all. hope those hints help.


    Oh and Dark... your too funny :hysterica

  4. #4
    liv
    liv is offline
    Former Moderator liv's Avatar
    Join Date
    Dec 2003
    Posts
    5,646
    oops.. re-read your post again.. loll.. i'm tired.. eh.. well.. first thing would be to check if you see the dev.. check /dev/rdsk and /dev/dsk. if its not there you will need to mount it via a script you can make or a in the /etc/vfstab.
    also check the format... and make sure its seen.. if not.. you got some bigger issues.. but if format sees the disk.. maybe all you need is to mount the raw disk.

    mount /dev/dsk/c0t0d0s0 /dev/rdsk/c0t0d0s0 /home

    if not try the share option
    share -F ufs -o rw=other -d "home" /home

    not sure what else to tell you...
    found this that might help you..
    http://www.mjmwired.net/resources/mj...fc6.html#samba

  5. #5
    Senior Member DARK's Avatar
    Join Date
    Aug 2004
    Posts
    1,765
    See Patrick even Liv thinks it would be "easier" for "you" to install XP...

  6. #6
    liv
    liv is offline
    Former Moderator liv's Avatar
    Join Date
    Dec 2003
    Posts
    5,646
    ROTFLMAO
    naaaa... install wine

  7. #7
    Moderator Krugar's Avatar
    Join Date
    Jun 2004
    Posts
    3,174
    emerge cedga

    Although after using gentoo for close to 3 years now, I'm thinking I spend more time updating & reparing it that I've gained from having a completely customised OS...

    Cheers!
    There is nothing so permanent as a temporary measure.

  8. #8
    Senior Member pwall's Avatar
    Join Date
    Nov 2004
    Posts
    2,326
    HI Liv.

    I checked out that link....thanks for sending that to me.
    I went thru it and I've done everything it mentions.
    Here is the list of directories that I'm sharing out via the smb.conf file:
    [tmp]
    path = /tmp
    writeable = yes
    browseable = yes
    valid users = pwall

    [home]
    path = /home
    writeable = yes
    browseable = yes
    valid users = pwall

    From my WindowsXP boxes, I can mount 'tmp' and use it with no issues. I can not mount 'home'. It's mouned on the linux box, that is where my home directory is.
    I'm replacing my older linux server (which is over 3 years old) and it is running a similar config with no issues. Except that it's Fedora version 1.

    Basically, I can share out any directory I want as long as it is not '/home' or anything beneith it.
    Regards,
    Patrick.
    Ottawa (Orleans), Ontario
    Yahoo IM: pwallnfld

  9. #9
    Senior Member pwall's Avatar
    Join Date
    Nov 2004
    Posts
    2,326
    So I tried remounting /home as /homedirs. Didn't work...still can't mount it.

    Here is what the fstab file looks like...maybe the disk is not mounted properly ?
    /dev/VolGroup00/LogVol00 / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0
    /dev/hdb /homedirs ext2 defaults 1 2
    Regards,
    Patrick.
    Ottawa (Orleans), Ontario
    Yahoo IM: pwallnfld

  10. #10
    Moderator Krugar's Avatar
    Join Date
    Jun 2004
    Posts
    3,174
    Did you check the permissions & ownership on /home itself?

    Cheers!
    There is nothing so permanent as a temporary measure.

Page 1 of 3 123 LastLast

Similar Threads

  1. Linux help!
    By chujai in forum Off Topic
    Replies: 4
    Last Post: 02-14-2007, 04:19 AM
  2. CCS skimmer issue
    By DuuhMojo in forum Just Getting Started
    Replies: 8
    Last Post: 03-21-2006, 07:21 PM
  3. HQI Ballast Issue
    By STEVE0 in forum Lighting, Filtration & Other Equipment
    Replies: 2
    Last Post: 02-23-2005, 09:06 PM
  4. Filtration Issue
    By Metropolis-Reef in forum Just Getting Started
    Replies: 13
    Last Post: 02-04-2005, 04:03 PM
  5. another end cap issue
    By orion in forum Lighting, Filtration & Other Equipment
    Replies: 1
    Last Post: 04-17-2004, 02:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •