Results 1 to 8 of 8
  1. #1
    Senior Member
    Join Date
    Jul 2006
    Posts
    183

    Annoying algae problems

    Hi all!
    Since i started my tank(july 06) i've always has algae problem.I'm aware that there is different stages that i will get algae in the tank.It's the green stuff(powder/strigny sometimes).
    I moved in december and just got rid of the old sand(aragonite) and bought new one.Everything went fine in the move,did not lost anything.I kept about 40% of the old water(RO)and made a new batch for the rest.I also seeded the sand with some old one(from a friend).Everything has always been doing great in my tank(rapid coralline growth,nice open corals,fish happy)tests are all within range.But again that algae is all over the glass again(when i moved i scrape all the glass to new looking).I just clean all the pumps,skimmer,glass 2 days ago and the algae is there again.

    I was ready to sell all of it but changed my mind(put lots of hours in there,more than money i think...lol)and want to try to figure out again what is wrong.
    Questions,suggestions?
    P.S. i did reading around and it's all different and i really dont know where to start again.
    Any help will be appreciated.Thanks!

  2. #2
    Senior Member
    Join Date
    Sep 2005
    Posts
    189

    Arrow Algae

    Try Some Mexican Turbo Snails they are awsome to clean out all the hair algae in a tank :biglaugh2

  3. #3
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    could you give a little more information ....

    your water params ? what brand test kits ?
    your clean up crew ?
    how big is the tank ?
    what skimmer are you using ?
    are you using any phosphate remover ?
    do you have a sump ?
    do you have a fuge ?
    any macro ?
    how often do you do water changes? how much ?
    what inhabitants do you have? how often do you feed them ? and what do you feed them ?
    how much flow do you have ?
    what are you using for filtration?


    i use a magfloat daily to remove the algae on the glass. this may be overkill but it is easier to do a little each day rather than have to scrap the glass every week or two.
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  4. #4
    Senior Member
    Join Date
    Jul 2006
    Posts
    183
    Hi here is some answer.As soon as i get back home i'll take the test and put the numbers up.Last test all was within range(5 days ago)

    your clean up crew ?
    I have snails(20)hermit(20)
    how big is the tank ?
    Tank is 55gal.
    what skimmer are you using ?
    I'm using Red Sea PRIZM
    are you using any phosphate remover ?
    No
    do you have a sump ?
    No i wish but i have no room for one.
    do you have a fuge ?
    No
    any macro ?
    No
    how often do you do water changes? how much ?
    5gal. weekly
    what inhabitants do you have? how often do you feed them ? and what do you feed them ?
    2 clown,1 blenny,cleaner shrimp.I feed them every 2 days(frozen mysis,brine shrimp,flakes)soaked garlic guard
    how much flow do you have ?
    I turn 1160gal/hour plus the skimmer.I'm running 4 Maxi's 1200
    what are you using for filtration?
    Live rock and i clean the gravel once in a while

  5. #5
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    Quote Originally Posted by AttiTude
    I have snails(20)hermit(20)
    what type?

    Quote Originally Posted by AttiTude
    I'm using Red Sea PRIZM
    i'm not familiar with that skimmer though i am familiar with other Red Sea skimmers and they're not worth the powder to blow them to hell. ( please anyone with experience with this skimmer let me know if it is any good ) how much do you pull and how thick is it?

    Quote Originally Posted by AttiTude
    2 clown,1 blenny,cleaner shrimp.I feed them every 2 days(frozen mysis,brine shrimp,flakes)soaked garlic guard
    just make sure that there isn't a lot of extra frozen food circulating around the tank. feed them only enough to eat in a short period of time. you can feed them a couple of times but make sure it's all getting eaten and not just blowing in the wind.

    with your inhabitants you could grow some Chaeto in you your tank to help remove nutrients.

    Quote Originally Posted by AttiTude
    I turn 1160gal/hour plus the skimmer.I'm running 4 Maxi's 1200
    those MJ's don't do much in a 4' tank ( guessing 48" x 13" x 20" ). if you put you hand 8" in front of the MJ can you even fell the water moving? i would consider upgrading the flow with a few seio's or similar ( maybe 1100's ). the idea is to keep everything in suspension rather than settling on the bottom. this allows your skimmer to remove them before they become a problem.


    a couple more questions

    what lights do you have? what photoperiod? and how old?

    what water do you use to make SW and top up?
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  6. #6
    Senior Member
    Join Date
    Jul 2006
    Posts
    183
    Here the test result as of 5pm Friday
    Salt 1.024
    Ammonia 0ppm
    Nitrate 2.5ppm
    Nitrite 0.2ppm
    Alk Normal
    P.H. 8.4
    I'm using Red Sea Marine test kit(i know it's not the best)
    My snails are: Nassarus and Astera
    Hermit are: blue leg and red leg
    The Prizm is not that bad but could be better.Pull mostly green stuff out and the skimmate is not that thick
    As for the MJ's i still have a mod left and will make a bracket this weekend to put it to use in my tank.
    My lightning is 6x48" 40w T12/t10 3 white/3 actinic act on 10am/off 0am,white on 12pm,off 22pm.All light were bought new in July06.
    I'm using Ivan's RO unit for water(got to get the meter)and i'm using Instant Oceal salt mix.
    I was mostly told to get a "good"skimmer and it will help alot.
    Suggestions on a good HOB skimmer?

    Thanks!

  7. #7
    Member
    Join Date
    Sep 2006
    Posts
    76
    i'd say your problems are nitrates and nitrites and maybe some phosphates

    a TDS meter would tell you how your RO/DI water is , that may also be the cause of some of your issues

  8. #8
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    the nitrites are a concern but are probably down to the test kit.

    skimming is very important. i saw an air mod for your skimmer on RC, i can PM you link if you want. from what i've read about HOB skimmers remora or deltec is the way to go.

    if i remember correctly T12's & T10's start to change color after 6 - 8 months and need to changed. you said everything was going along great then the algae started again. so this just started recently?

    the RO unit, how old are the filters and membrane and do you have a DI stage? if you take sample into your LFS they may test it for you. make sure you run the unit for 10 min before taking your sample as there is usually a spike when you first turn the RO on.

    it is probably a combination of things, the key is to remove the organic waste before it can become a problem. adding the Mj mod will help to keep things in suspension allowing your skimmer to get it. your lighting could be a factor, as they change spectrum they can fuel algae growth.

    you could try running some phosphate absorbtion material in a sock hanging in front of a power head ( not nice to look at but may help ). and as i said before maybe try some chaeto ( macro algae ) or similar in the tank. chaeto uses both nitrates and phosphates to grow. the best way i've found to get rid of the hair algae is to just keep pulling it out and get your nutrients in order.

    HTH
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

Similar Threads

  1. Ich problems
    By todd in forum Fish Disease Treatment
    Replies: 11
    Last Post: 12-19-2010, 11:46 PM
  2. Coralline Algae .. problems with non-growth
    By jklink in forum Reef Discussion
    Replies: 17
    Last Post: 11-10-2006, 01:24 PM
  3. Ick problems
    By northernboy in forum Just Getting Started
    Replies: 3
    Last Post: 09-09-2006, 12:31 AM
  4. Is it coralline algae? or nuisance algae?
    By Swimfins in forum Just Getting Started
    Replies: 0
    Last Post: 02-11-2006, 04:50 PM
  5. Help...2 problems at once!
    By Salty Steve in forum Reef Discussion
    Replies: 1
    Last Post: 11-07-2004, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •