Results 1 to 8 of 8
  1. #1
    BWI
    BWI is offline
    Sponsor BWI's Avatar
    Join Date
    Dec 2007
    Posts
    188

    ID on the Unknown!!

    i was cleaning the sump and found these 2 things in the cheato..

    what are they and are they GOOD or BAD?




    Building Quality not Quantity

  2. #2
    BWI
    BWI is offline
    Sponsor BWI's Avatar
    Join Date
    Dec 2007
    Posts
    188
    also is anyone else getting a scum on the surface of the water in their fuges?

    Building Quality not Quantity

  3. #3
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    scypha sponge ( AKA q-tip sponge ) and a stomatella snail ( better picture for sure ), both very good and not a problem
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  4. #4
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    Quote Originally Posted by BWI View Post
    also is anyone else getting a scum on the surface of the water in their fuges?
    the scum can be prevented by changing the way your water enters your fuge, ( i'm going looking for pics of you r set up )
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  5. #5
    BWI
    BWI is offline
    Sponsor BWI's Avatar
    Join Date
    Dec 2007
    Posts
    188
    perfect thanks !!!!!! i know its the way the water goes into the fuge.. its ok i have an idea to fix it! thanks again

    Building Quality not Quantity

  6. #6
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    Quote Originally Posted by BWI View Post
    perfect thanks !!!!!! i know its the way the water goes into the fuge.. its ok i have an idea to fix it! thanks again

    found the pics in your tank thread. the problem is that the water comes over the last bubble trap ( from skimmer section ) and runs down the side rather than across the top. by increasing the water level in the fuge so it is above the last bubble trap from the skimmer section the water will come in and run across the surface. to do this you would have to increase the height of the last bubble trap before the return section.

    if that makes any sense :b7:
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  7. #7
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    sorry to many beers, i see now that the water comes in low and out low from the fuge. the easiest fix would be to put a small powerhead in the fuge to stir it up .
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  8. #8
    BWI
    BWI is offline
    Sponsor BWI's Avatar
    Join Date
    Dec 2007
    Posts
    188
    yea i was going to do that. The 2nd baffle after the skimmer is just sitting there so i could take it out but i find that the mic bubbles go down and then slow down and come up and pop leaving me with almost non in the DT. I may just let it run with out that baffle for a day or to and move the water around a little more and then put it back in.. cheers!!!

    Building Quality not Quantity

Similar Threads

  1. Replies: 2
    Last Post: 02-02-2011, 05:30 PM
  2. unknown critter
    By BWI in forum Reef Discussion
    Replies: 6
    Last Post: 12-06-2007, 10:28 PM
  3. Unknown Tube Worm in tank
    By fishmonger in forum Reef Discussion
    Replies: 16
    Last Post: 02-27-2005, 11:03 PM
  4. Unknown problem in my tank
    By Nanosteve in forum Just Getting Started
    Replies: 9
    Last Post: 12-11-2004, 04:10 PM
  5. unknown shrimp (No pic.)
    By Gools in forum Reef Discussion
    Replies: 1
    Last Post: 11-07-2004, 10:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •