Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: ID please.

  1. #1
    Senior Member todd's Avatar
    Join Date
    Dec 2008
    Posts
    176

    ID please.

    can someone ID this please, i'm at a loss as to what it is. i got it on a piece of live rock i bought a while ago, it seems to be spreading, slowly.

    thanks for the help.
    Todd
    Attached Thumbnails Attached Thumbnails ID please.-id.jpg   ID please.-id1.jpg  

  2. #2
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    any chance of a clearer shot???

    or a bit of a description???? ( hard / soft, does it eat????, move??, etc...... )
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  3. #3
    ijo
    ijo is offline
    Moderator
    Join Date
    May 2011
    Posts
    6,610
    Looks like a Hydnophora SPS... my guess so far



    IJO

  4. #4
    Senior Member todd's Avatar
    Join Date
    Dec 2008
    Posts
    176
    all i can really say is that when it gets stressed out, all the tiny bumps it has all over it, kinda like little polyips they all retract, and the color turns all brown grey. i dont really feed it ever, i' have put some phytoplankton on it, just to keep it around maybe it liked it i dont know
    anyways, thanks for the help!

    Todd

  5. #5
    Senior Member todd's Avatar
    Join Date
    Dec 2008
    Posts
    176
    Oh and as for the other picture no, my camera is a bit crappy.
    thanks
    Todd

  6. #6
    Former Moderator a4twenty's Avatar
    Join Date
    Nov 2006
    Posts
    2,819
    i know it's tough to get good pics, i've spent hours perfecting my techniques and setting everything up just right :b16:

    try offering something larger ( zooplankton ( cyclop-eeze or even mysis )
    `

    120S RR tank with 60G basement sump / fuge

    Return Pump: Little Giant 4-MDQX SC
    Water Movement: MP40W, Seio 1500, (2) Hydor K4's
    Lighting: 400W SE MH with 10K Venture
    Skimmer: Euro-Reef RS250 with gate valve
    Other: RODI, RDSB, PO4/AC reactor


    My Gallery

  7. #7
    ijo
    ijo is offline
    Moderator
    Join Date
    May 2011
    Posts
    6,610
    Does it look close to the image I provided?

    IJO

  8. #8
    Senior Member todd's Avatar
    Join Date
    Dec 2008
    Posts
    176
    not really, and i even went to google the name too, it doesnt have all those polyips, it's bumpy, almost looks a bit hairy haha.
    and i have it under 2X T5HO seems to be doing well under those.

  9. #9
    Moderator ShipWreck's Avatar
    Join Date
    Oct 2004
    Posts
    1,213
    Is it like these pics? I have a similar story to yours, it was a little thing on a small rock and it has slowly encrusted more rock. It normally has little bright green feeding tentacles around the center of each polyp but I had to move it to the front of the tank for a pic so they receded.

    Without flash



    With Flash

    Rob
    -----
    Upgrade in the works! Keep looking for an update.


  10. #10
    Senior Member todd's Avatar
    Join Date
    Dec 2008
    Posts
    176
    YEAh thats kinda what it looks like, but it's like shag carpet all over. maybe it's to small to actually have a mouth yet, but thats the closest pictures iv seen to what it is. do you have any idea what it is?! if it eats... pretty much any info would be good
    thanks
    Todd

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •